Skip to main content

Article ID

2065

Product Version

AhsayOBM / AhsayACB: 9.1 to 9.11.2

Operating System

Windows

Symptom

The file backup failed and the report contains the following entries:

YYYY/MM/DD hh:mm:ss [info] [1565605275414] Creating Shadow Copy for all volumes: \\?\Volume{62c69ed8-cf1d-11e7-80b4-806e6f6e6963}\, V:\, F:\, R:\, Q:\, S:\, P:\, C:\, \\?\Volume{a946b8c0-24dc-11eb-80fc-8dad3f560946}\, D:\, E:[2023/05/21 20:00:39] [info] [-] "\\?\Volume{a946b8c0-24dc-11eb-80fc-8dad3f560946}\" cannot use Volume Shadow Copy backup, backup this volume by using normal operation!!
YYYY/MM/DD hh:mm:ss [erro] [BackupFileCmd.uploadBackupFiles][java.io.FileNotFoundException] Error=java.io.FileNotFoundException

Cause

To support backups of volume mount points on Windows file backup sets on AhsayOBM/AhsayACB, if "Volume Shadow Copy" option is enabled , AhsayOBM/AhsayACB will initiate a VSS snapshot of all local drives found on the machine regardless if the drive has been selected in the backup source.

Resolution

  1. Close the AhsayOBM / AhsayACB user interface then stop the AhsayOBM / AhsayACB service.
  2. Browse to the backup client installation folder. (e.g. C:\Program Files\AhsayOBM or C:\Program Files\AhsayACB)
  3. Open the cb.opt file with a text editor.
  4. Edit the line:

    com.ahsay.obx.core.backup.file.ShadowCopy.disableAddAllVolumes=

    Change to:

    com.ahsay.obx.core.backup.file.ShadowCopy.disableAddAllVolumes=true
  5. Save the file.
  6. Restart the AhsayOBM / AhsayACB service.

Once done, perform a manual backup or wait for the next scheduled backup and check if the issue is resolved