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Unable to open index file, caused by [RuntimeException]

Article ID
2033
Product Version
AhsayACB / AhsayOBM: 7.x or above
Operating System
Windows
Symptom

When performing a backup of any type, the following error message is received in the backup report:

No. Type Timestamp Log
info
* info YYYY/MM/DD hh:mm:ss Using Temporary Directory drive_letter\
path_with_special_characters
\temp\backupset_id
\Local@
erro
* erro YYYY/MM/DD hh:mm:ss [g] [BackupSetIndex.init], caused by [g] [BackupSetIndex.getBfsBbd] Unable to open index file, caused by [RuntimeException] [BlockDBConfig.readConfig] unknown default path for creating new journal file config: 0
This issue will only affect backup set with temporary path containing one or more special characters (e.g. ~, !, @, #, $, %, ^, &, (, ), _, +, `, -, =, {, }, [, ], ;, ', ,)
Cause

The issue is caused by the temporary path of the corresponding backup set containing one or more special characters, which includes:

~, !, @, #, $, %, ^, &, (, ), _, +, `, -, =, {, }, [, ], ;, ', ,

Bad Padding Exception

Resolution
  • Renaming the temporary folder

    The primary way to resolve this issue is to rename the temporary folder/folders with a name that does not contain any special characters, which includes:

    ~, !, @, #, $, %, ^, &, (, ), _, +, `, -, =, {, }, [, ], ;, ', ,

    For example:

    C:\temp_path\with_no_special_character

  • Patch AhsayOBM / ACB to latest release

    Another way to fix the issue is by patching the affected clients to the latest release for AhsayOBM / ACB. These latest versions, in the case of both v7 and v8, serve as the final versions for both AhsayOBM and ACB, due to both v7 and v8 already being in an EOL (End-of-Life) state.

    It is suggested that users patch their clients to these latest versions, which are:

    • v7: (7.17.2.2)

    • v8: (8.7.0.0)

    For instructions on how to upgrade your AhsayOBM / ACB to these latest versions, click here.

    It is suggested that users should review the EOL pages of both v7 and v8, as each EOL page provides details such as roadmaps for the EOL cycle, as well as other useful information like the scope of Ahsay's support for these product versions.

    You may read these EOL pages through the links below:

  • Applying Hotfixes

    After patching the affected clients to the latest release, you may wish to further enhance your experience by downloading and applying hotfixes.

    You may find and download the compatible hotfixes for these versions from the links below:

    Once you have secured your preferred hotfix, you can follow this guide on how to apply your downloaded hotfix to AhsayOBM or ACB.