Cannot open the client user interface with error failed to obtain IV from input stream
Article ID
Product Version
Operating System
Symptom
When opening the AhsayOBM / ACB user interface, the following error message is displayed:
"[PBEInputStream.init] Failed to obtain IV from input stream]"
Cause
This issue can occur if the AhsayOBM / ACB user settings files (e.g. ~\.obm\config\settings.sys) saved on the client computer is corrupted.
Resolution
To login to the AhsayOBM / ACB client, please remove, then re-create the user settings file on the affected client computer.
Before proceeding to the next step, ensure that you have the encryption key for all backup sets of the affected user. Re-creating the user profile will require you to enter the encryption key for all existing backup set.
For more details and best practice for managing encryption key, refer to the following Know-How article: Best practices for managing encryption key on AhsayOBM or AhsayACB.Refer to the following steps to resolve the issue:
- Stop the AhsayOBM / ACB services
-
Locate the settings.sys file in the .obm / .acb folder at:
%UserProfile%\.obm\config\settings.sys
or
%UserProfile%\.acb\config\settings.sys
Exact path to the .obm / .acb folder is saved in the home.txt file found at:
C:\ProgramData\AhsayOBM\home.txt
or
C:\ProgramData\AhsayACB\home.txt - Rename the setting.sys file to BACKUP_settings.sys
-
Login to the AhsayOBM / ACB user interface
At this point, the client will prompt for encryption key of all existing backup sets. You must enter the correct encryption key of each backup set to regain access to them.