Article ID
Product Version
Operating System
Symptom
When performing a file backup, the following message is received in the backup report:
[info] YYYY/MM/DD hh:mm:ss [-] Contact your service provider to enable [Volume Shadow Copy] support
...
[erro] YYYY/MM/DD hh:mm:ss [New File] File="C:\%path%\Masterlist.xlsx" Error="com.ahsay.afc.io.SharingViolationException: [CreateFileW] (32) The process cannot access the file because it is being used by another process.
Cause
The error indicates that when AhsayOBM / AhsayACB is trying to read the above file during the backup process, this file is open, i.e., it may be used by the client.
For the backup of open files located on the local disk of a Windows machine, AhsayOBM / AhsayACB uses the Windows Volume Shadow Copy service to create a snapshot of the volume so it can be backed up without conflicting with other applications that may be using these files.
Resolution
To resolve the issue, please check if the Volume Shadow Copy is enabled on User Profile and Backup Set.
- Go to Backup / Restore > Users, Groups & Policies > Backup User > %backup_user% > User Profile > Backup Client Settings > Add-on Modules.
Check if the checkbox beside Volume Shadow Copy is ticked, if not tick the checkbox.
- Next go to Backup Set > %backup_set_name% > Others > Volume Shadow Copy.
Check if the checkbox beside Enable Windows' Volume Shadow Copy for open file backup is ticked, if not tick the checkbox.
- Click Save to save the settings.
For files located on a network folder, you will need to make sure that the files are not being used when the backup runs, or you can create a filter on the backup set to exclude the open files that start with $.