Cannot open the client user interface due to corrupted user settings file
Article ID
Product Version
Operating System
Symptom
There are several errors that can be encountered related to corrupt user settings file.
Here are some errors that users may encounter upon opening the AhsayOBM / AhsayACB user interface:
"javax.crypto.BadPaddingException: pad block corrupted"
"Invalid byte 1 of 1-byte UTF-8 sequence"
"Content is not allowed in prolog."
"Failed to obtain salt from input stream"
Cause
This issue can occur if the AhsayOBM / ACB user settings file (e.g. ~\.obm\config\settings.sys) saved on the client computer is corrupted.
Resolution
To resolve the issue, remove, then re-create the user settings file on the affected client computer.
For more details and best practice for managing encryption key, refer to the following KB article: Best practices for managing encryption key on AhsayOBM or AhsayACB.
Refer to the following steps to resolve the issue:
- Stop the AhsayOBM / ACB services
-
Locate the settings.sys file in the.obm / .acb folder at:
%UserProfile%\.obm\config\settings.sys or
%UserProfile%\.acb\config\settings.sysExact path to the .obm / .acb folder is saved in the home.txt file found at:
C:\ProgramData\AhsayOBM\home.txt or
C:\ProgramData\AhsayACB\home.txt -
Rename the settings.sys file to 'BACKUP_settings.sys'
-
Login to the AhsayOBM / ACB user interface.
At this point, the client application will prompt for encryption key of all existing backup sets. You must enter the correct encryption key of each backup set to regain access to them.