Skip to main content

Article ID

2036

Product Version

AhsayOBM: 8.1 and above

Operating System

Windows

Symptom

When performing an MS Exchange 2013 / 2016 / 2019 mail level (EWS backup set) restore, the following error is displayed:

[erro][Restorer.run] Path=C:\Program Files\AhsayOBM\bin\Microsoft
Exchange\Mailboxes\JoeB@ahsay.com\Inbox\bugfixes\AAMkADUxNjhkODg1LWFlNDQtNDljNS1iNTMzLTQ3N2Q5YjRlZGVhNwBGAAAAAAA tQ%2B7WX6hwQptsGViTE4fABwA%2BwxyUxB%2BwRJavUCIvAGz4AAA4PiD%2BAADlBtLq%2F4Throwable= [N] [ServiceException] Message = The message exceeds the maximum supported size., Cannot save changes made to an item to store., response code = ErrorMessageSizeExceeded

Cause

This issue can occur on an MS Exchange server if message size limits have not been setup correctly. The default message size settings are usually 30MB.

Resolution

To resolve this issue, update the message size limits on the affected MS Exchange server:

  1. Login to the MS Exchange Server.
  2. Open Exchange Management Shell
  3. Run the following cmdlet to increase the message size limits to 150MB.

    >Set-TransportConfig -MaxReceiveSize 150MB -MaxSendSize 150MB
    
    >Get-SendConnector | Set-SendConnector -MaxMessageSize 150MB
    
    >Get-ReceiveConnector | Set-ReceiveConnector -MaxMessageSize 150MB
    
    >Get-Mailbox | Set-Mailbox -MaxSendSize 150MB -MaxReceiveSize 150MB

For details, refer to the following Microsoft document:
https://docs.microsoft.com/en-us/exchange/configure-client-specific-message-size-limits-exchange-2013-help?redirectedfrom=MSDN