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Failed to mkdir / Failed to list path (error when enabling Replication to another AhsayCBS server)

Article ID
2015
Last Reviewed Date
Product Version
AhsayCBS: 9.1 or above
Operating System
All platforms
Symptom

The following error is displayed on the AhsayCBS web console when enabling replication to another AhsayCBS server:

"Failed to mkdirs, path: settings, (com.ahsay.afc.cloud.d: [RpsManager.list] Failed to list path: . Reason: Precondition Failed)"

error message

Cause

This issue can be caused by one of the following reasons:

  1. The Receiver was not created on the AhsayCBS (receiver) server.
  2. The Receiver on the AhsayCBS (receiver) server is not enabled.
  3. The Replication User login credentials entered on the AhsayCBS (sender) server are incorrect.
  4. The port number for Replicate v6 backup sets to v7 or above server setting on the AhsayCBS (sender) server is incorrect.
  5. The Enable V6 Backup Sets Replication setting is not enabled on the AhsayCBS (receiver) server.
  6. There is a license related issue in the AhsayCBS (receiver) server, i.e. License 1012 error, evaluation key expired.
Resolution

To resolve issue 1:

  1. Login to the AhsayCBS (receiver) server web console.
  2. Under Replication, select Accepting Data > Receiver > Manage Receiver to create a receiver.

    Receiver

To resolve issue 2:

  1. Login to the AhsayCBS (receiver) server web console.
  2. Under Replication, select Accepting Data > Receiver > Manage Receiver, select the corresponding receiver.
  3. Tick the Enable Replication checkbox then save.

    Receiver

To resolve issue 3:

  1. Login to the AhsayCBS (sender) server web console.
  2. Under Replication, select Sending Data.
  3. Disable then re-enable Replication backed up data to another server or predefined cloud storage.
  4. Re-enter the correct login credentials under Replicate User Name and Replicate User Password then save.

    Receiver

To resolve issue 4:

  1. Login to the AhsayCBS (sender) server web console.
  2. Under Replication, select Sending Data.
  3. Disable then re-enable Replication backed up data to another server or predefined cloud storage.
  4. Confirm that the Port (SSL) setting under Replicate v6 backup sets to v7 server is correct, then save.

    Receiver

To resolve issue 5:

  1. Login to the AhsayCBS (receiver) server web console.
  2. Under Replication, select Accepting Data > Receiver > Manage Receiver, select the corresponding receiver.
  3. Confirm that the Bind to IP address setting (e.g. port and IP address) under Enable V6 Backup Sets Replication is correct, then save.

    Receiver