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Failed to check integrity of destination

Article ID
2049
Product Version
AhsayACB / AhsayOBM: 8.1 and above
Operating System
Windows
Symptom

When performing a Data Integrity Check, the following backup error is received in the Integrity Check log:

unix_time,ERROR,"Failed to check integrity of destination \"-id\". Error: \"[RuntimeException] Database Index \"C:\\Users\\username\\temp\\backupset_id\\Predefined@-id\\index\\migrate\\index\\index.db\" is in use.\""

The same message can also be found in the backup report as info:

No. Type Timestamp Log
info
* info ... Download valid index files from backup job "Current" to "C:\Users\username\
temp\backupset_id\
Predefined@-id\index".
info
* info YYYY/MM/DD hh:mm:ss Failed to check integrity of destination "-id". Error: "[RuntimeException] Database Index "C:\Users\username\
temp\backupset_id\
Predefined@-id\index\
migrate\index\index.db" is in use."
Cause

The issue can occurs if the temporary folder of the affected backup set is being indexed by the Windows Search service.

Resolution

To resolve the issue:

  1. First, confirm if there are multiple bJW.exe processes running on the computer at the same time.

    • Open Task Manager, check if there are multiple bJW.exe processes under Details.

      step1

      If there are multiple bJW.exe processes running. close the AhsayOBM / ACB user interface, then kill the remaining bJW.exe process(es). Move onto the next step if there is only one bJW.exe process.

  2. Next, you can:

    • Option 1 - Change the temporary folder setting of the affected backup set to another location that is not indexed by the the Windows Search service. By default, search indexing is enabled for C:\Users, where the default temp path reside.

      option

      To resolve the issue for all backup set, you should change the temporary folder setting for all backup sets.
    • Option 2 - Alternatively, you can exclude the temporary folder from being indexed:

      • In the Start Menu, search for Indexing Options.

        option2

      • Click Modify.

        modify

      • Un-select the temporary directory (e.g. C:\Users\username\temp).

        unselect

      • Click OK, then Close.

  3. Performing another Data Integrity Check afterward to see if the problem persist.