Article ID
Product Version
Operating System
Symptom
When performing an MS Exchange Mail Level restore, the following error is shown in the restore log:
No. | Type | Timestamp | Log |
---|---|---|---|
erro | |||
* | erro | YYYY/MM/DD hh:mm:ss | [PostRestoreMailTask.run] Path=SERVER\Mailbox Store\Mailbox\ Folder\mail_item Throwable=NewMessage Error=MAPI_ E_CALL_FAILED Detail=Unspecified error |
Cause
This issue can occur if the mail item(s) to be restored exceeded the message size limits (MaxReceiveSize) setting configured for the restore Destination Exchange server.
Resolution
To resolve the issue, temporarily configure the maximum message size that can be received by recipients in the organization (MaxReceiveSize) to unlimited, before performing the restore.
Check on the current "MaxReceiveSize" setting of the restore destination Exchange server, enter the following command in Exchange PowerShell:
Get-TransportConfig | fl
For more details on the Get-TransportConfig cmdlet, refer to: https://docs.microsoft.com/en-us/.../get-transportconfig
Temporarily modify the "MaxReceiveSize" setting to unlimited, enter the following command in Exchange PowerShell:
Set-TransportConfig-MaxReceiveSize unlimited
For more details on the Set-TransportConfig cmdlet, refer to: https://docs.microsoft.com/en-us/.../set-transportconfig
- Perform the MS Exchange Mail Level again afterward.