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Please use the following steps on Failed to check integrity of destination.

Symptom:

When performing a Data Integrity Check, the following backup error is received in the Integrity Check log:

unix_time,ERROR,"Failed to check integrity of destination \"-id\". Error: \"[RuntimeException] Database Index \"C:\\Users\\username\\temp\\backupset_id\\Predefined@-id\\index\\migrate\\index\\index.db\" is in use.\""

The same message can also be found in the backup report as info:

  • Download valid index files from backup job "Current" to "C:\Users\username\temp\backupset_id\Predefined@-id\index".
  • Failed to check integrity of destination "-id". Error: "[RuntimeException] Database Index "C:\Users\username\temp\backupset_id\Predefined@-id\index\migrate\index\index.db" is in use."

Cause:

The issue can occurs if the temporary folder of the affected backup set is being indexed by the Windows Search service.

Resolution:

To resolve this issue:

  1. First, confirm if there are multiple bJW.exe processes running on the computer at the same time.
    • Open Task Manager, check if there are multiple bJW.exe processes under Details.
    • If there are multiple bJW.exe processes running, close the AhsayOBM / AhsayACB user interface, then kill the remaining bJW.exe process(es). Move onto the next step if there is only one bJW.exe process.




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  2. Next, you can:
    • Option 1 - Change the temporary folder setting of the affected backup set to another location that is not indexed by the Windows Search service. By default, search indexing is enabled for C:\Users, where the default temp path reside.

      Note:

      To resolve the issue for all backup set, you should change the temporary folder setting for all backup sets.

    • Option 2 - Alternatively, you can exclude the temporary folder from being indexed:
      • In the Start Menu, search for Indexing Options.
      • Click Modify.
      • Unselect the temporary directory (e.g. C:\Users\username\temp).
      • Click OK, then Close.

  3. Perform another Data Integrity Check afterward to see if the problem persists.